Что такое Reg Organizer

Reg Organizer - это программа для комплексного обслуживания операционной системы Windows. С ее помощью можно чистить систему от ненужных файлов, оптимизировать программы автозапуска, редактировать реестр Windows, осуществлять поиск и замену в реестре, полностью удалять ненужное программное обеспечение, создавать и сравнивать снимки ключей реестра, выявляя изменения, произошедшие в системе, а также в наглядной форме просматривать важные разделы реестра.

Также программа позволяет включить труднодоступные и недокументированные возможности операционной системы - так называемые тонкие настройки, - отменять изменения, внесенные в систему, и очищать систему от следов вашей работы на ней, содержащих данные персонального характера, такие, как список последних открытых вами документов и история браузера.

Если вы новый пользователь, то для начала рекомендуем ознакомиться со следующими разделами справочного руководства:

Как работать с программой (если вы новый пользователь)
В этом разделе содержится информация о том, как быстро освоиться с программой новым пользователям. Информация, приведенная здесь, позволит в максимально короткие сроки начать эффективно использовать программу Reg Organizer на вашем компьютере.
Обзор основных функций программы
Данная статья содержит описание основных функций программы Reg Organizer и ссылки на более подробную информацию по каждому из имеющихся инструментов.
Авторские права © ChemTable Software. Все права защищены.


Быстрый старт

Как быстро найти и исправить проблемы в системе
Как работать с программой
Основные функции Reg Organizer


Как быстро найти и исправить проблемы в системе

В программе Reg Organizer есть функция экспресс-проверки системы, которая позволяет за несколько секунд проверить основные компоненты операционной системы и в случае выявления рекомендаций провести их немедленное выполнение. Это очень удобный инструмент, позволяющий быстро оценить, насколько устройства компьютера заполнены ошибочными и ненужными файлами, нуждается ли автозапуск системы в оптимизации и т. д.

По умолчанию функция экспресс-проверки системы выполняется автоматически при первом запуске Reg Organizer, а также при следующих запусках, если не отключить соответствующую опцию в окне функции.

Запустить экспресс-проверку можно и вручную, выполнив следующие шаги:

  • В главном меню программы откройте подменю «ФУНКЦИИ».
  • Выберите команду «Экспресс-проверка».

Программа начнет проверку основных компонентов системы. Обратите внимание, что работу экспресс-проверки можно в любой момент прервать, просто перейдя к любой другой функции программы.

Результаты проверки будут показаны в главном окне программы. Для выполнения рекомендации щелкните по кнопке рядом с описанием рекомендации, чтобы запустить соответствующий инструмент.

Например, программа обнаружила, что есть возможность провести чистку системы от ненужных файлов, освободив дополнительное место на дисках. Для запуска чистки системы в блоке «ЧИСТКА» нажмите на любую часть этого блока. Программа переключится в соответствующий инструмент, и от вас потребуется лишь несколько кликов, чтобы провести чистку.


Как работать с программой

Основная функциональность программы Reg Organizer реализована в виде различных инструментов: например, инструмент для чистки системы, просмотра программ автозапуска, редактирования реестра и других. Все они представлены в панели в левой части основного окна программы. Можно быстро открыть любой инструмент, кликнув по его названию. Инструменты объединены в группы для разных категорий пользователей: для всех, только для специалистов и еще одна группа, в которой находятся инструменты, не отнесенные ни к одной из этих групп.

Также быстро перейти к интересующему инструменту можно через подменю «ФУНКЦИИ» главного меню программы.

Если вы не знаете, с какого из инструментов следует начать работу с программой, то запустите экспресс-проверку системы. Эта функция проведет быстрый анализ вашей системы и в случае обнаружения рекомендаций сама подскажет, какие инструменты Reg Organizer следует использовать для приведения системы в порядок.

Чтобы узнать больше о каждом из инструментов, имеющихся в Reg Organizer, обратитесь к этому разделу.


Инструменты, имеющиеся в Reg Organizer

Программа Reg Organizer предоставляет пользователю следующие инструменты:

Экспресс-проверка
Представляет собой «центр управления», где отображается статус системы, например, много ли присутствует ненужных файлов на дисках, и приведены рекомендуемые программой Reg Organizer действия. Инструмент идеально подходит для неопытных пользователей.
Чистка системы
Этот инструмент предназначен для освобождения места и избавления от информационного мусора на дисках вашего компьютера. Также он позволяет произвести поиск и исправление разных типов проблем в реестре и системе. Инструмент подойдет и для начинающих пользователей.
Чистка личных данных
Инструмент предназначен для удаления из системы следов работы за компьютером, содержащих персональные сведения о пользователе, а также чистки следов работы (кэша) установленных программ. Может использоваться и неопытными пользователями.
Автозапуск программ
Предлагает вашему вниманию список программ, зарегистрированных для автоматического запуска вместе с системой. Помимо просмотра и редактирования этих программ, позволяет ускорить загрузку компьютера с помощью откладывания программ, запуская их не одновременно с загрузкой системы, а несколько позднее.
Программы
С помощью этого инструмента можно обновлять установленные у вас программы, а также полностью удалить ненужные программы из системы. Во время установки программы Reg Organizer следит за системой, выявляя изменения, происходящие в ней в процессе установки программы. Если программу потребовалось удалить, эти данные используются для ее полного удаления из системы. Таким образом, будут подчищены даже такие следы программы, которые остались после стандартной процедуры удаления.
Редактор реестра
Позволяет выполнять весь спектр операций с ключами и параметрами, включая создание, изменение, копирование, удаление и поиск. Есть возможность экспортировать или импортировать данные реестра. Инструмент включает в себя редактор файлов реестра (.reg). Он позволяет работать с файлами реестра, используя интерфейс редактора реестра, то есть так, как если бы вы работали непосредственно с реестром, а не .reg-файлом.
Важные разделы реестра
Эта функция программы извлекает информацию из наиболее важных ключей реестра и представляет их вам в наглядной форме. Такая функция во многих случаях избавит вас от необходимости искать и открывать нужные ключи в редакторе реестра, а также проверять записи в них на правильность. Программа соберет эту информацию сама, проанализирует и представит вам в наглядной форме. К примеру, с этой функцией можно легко просмотреть и отредактировать список недавно открытых в различных приложениях документов, исследовать общие библиотеки динамической компоновки (DLL) и многое другое. Программа может сделать просмотр этой информации более простым, разделяя элементы на разные группы. Например, можно выделить в отдельную группу некорректные записи или записи, которые появились в реестре недавно.
Тонкие настройки системы
Этот инструмент позволяет настраивать работу операционной системы под ваши предпочтения. Например, вы можете ускорить работу системы, указав системе использовать кэш-память большего объема, или расширить список команд, доступных в Проводнике Windows, и многое другое.
Снимки реестра
Этот инструмент предоставляет возможность создания и сравнения состояния реестра в разные периоды времени, выявляя изменения.
Оптимизация реестра (устаревший инструмент)
Этот инструмент был эффективен в эпоху операционной системы Windows XP и более ранних. С его помощью при работе под указанными системами программа может оптимизировать работу Windows путем сжатия и дефрагментации реестра. Во время сжатия происходит удаление из файлов реестра избыточной информации. Дефрагментация объединяет все фрагменты файлов реестра воедино, что ускоряет обращение к реестру и, как следствие, скорость работы системы в целом. Оптимизация выполняется в автоматическом режиме, поэтому данный инструмент могут использовать и начинающие пользователи.


Чистка системы

Для чего предназначена эта функция
Чистка реестра
Выполнение чистки системы
Режим максимальной чистки
Очистка заданных пользователем файлов
Список исключений


Для чего предназначена эта функция

Данный инструмент позволяет производить чистку устройств компьютера от ненужных файлов, выполнять поиск и исправление неверных ярлыков, т.е. неверных ссылок на программы и документы, чистить реестр, а также проводить ряд других мероприятий по увеличению свободного места на диске, например, удаляя ненужные файлы функции обновления Windows.

Необходимость периодической чистки дисков обусловлена тем, что в процессе работы приложений и самой операционной системы создается множество временных файлов, которые в совокупности могут занимать весьма значительный объем дискового пространства. К сожалению, не все программы удаляют эти файлы после того, как необходимость в их использовании исчезает. Ситуация усугубляется тем, что без принятия специальных мер объем дискового пространства, растрачиваемый впустую на хранение этих временных файлов, только увеличивается.

Многие приложения в процессе своей работы создают файлы во временной папке. В случае некорректного закрытия приложения эти файлы остаются на жестком диске. Если не производить очистку временных папок, то там накапливается информационный мусор.

Выполнять ручной поиск и удаление подобных файлов неудобно, поэтому лучше использовать для этих целей инструмент для чистки системы программы Reg Organizer.


Чистка реестра

В современных операционных системах чистка реестра не приносит значимой пользы и оставлена в программе, как «наследие» эпохи Windows XP и более ранних систем. Приведенные ниже полезные свойства чистки реестра относятся прежде всего к Windows XP и более ранним системам.

В рамках функции чистки системы производится также поиск и удаление неверных записей в системном реестре.

При установке приложений в реестр Windows добавляются новые записи. Также он увеличивается в размерах за счет данных, вносимых установленными программами. К сожалению зачастую даже при корректном удалении приложения с помощью его собственной функции деинсталляции не вся информация, добавленная приложением в реестр, будет удалена.

Как правило, при работе в современных версиях операционной системы Windows наличие таких лишних или неверных записей не сказывается на скорости ее работы. Однако в некоторых случаях наличие неверных записей реестра может приводить к ошибкам в работе приложений.

Кроме того, в ряде случаев удаление неверных записей из реестра позволяет убрать из интерфейса Windows ссылки на уже не актуальные файлы. Например, чистка системы в программе Reg Organizer позволяет стереть ссылки на перемещенные или удаленные файлы из выпадающих списков в окнах открытия и сохранения файлов в приложениях Windows. Это приведет к тому, что во всех приложениях, где используется диалог открытия или сохранения файла, в данном диалоге будут содержаться только актуальные записи.


Выполнение чистки системы

Если вы не пользовались утилитами для очистки от информационного мусора, то наверняка на вашем компьютере есть ненужные файлы, мертвым грузом оседающие на жестких дисках и занимающие драгоценное дисковое пространство. Различные временные файлы, создаваемые приложениями и самой операционной системой во время работы, лог-файлы, содержащие отчет о действиях системных утилит, - все это примеры бесполезных и ненужных файлов, от которых можно и нужно избавиться.

Чтобы открыть инструмент для выполнения чистки системы, выберите соответствующую команду в подменю «ФУНКЦИИ» главного меню.

Для того чтобы начать поиск ненужных файлов и других проблем, нажмите кнопку «СКАНИРОВАТЬ». Если вы перешли в этот инструмент из функции экспресс-проверки системы, то нажимать кнопку даже не потребуется, поскольку сканирование начнется автоматически.

Во время сканирования вы увидите сменяющие друг друга разделы системы, которые проверяются функцией чистки, какие как «временная папка. Каждый из них соответствует месту в системе, где обычно располагаться информационный мусор, неверные файлы, записи реестра и т.д.

Смысл раздела чистки бывает легко понять из его названия. Ниже приведены особенности некоторых разделов:

  • Неверные ярлыки
    В рамках сканирования этого раздела чистки системы программа проведет поиск ярлыков, которые указывают на несуществующий объект (файл или папку) и исправит или удалит их. По умолчанию неверные ярлыки удаляются, но вы можете указать, чтобы программа пыталась отремонтировать их. Для этого откройте окно настроек, выбрав в главном меню пункт «НАСТРОЙКИ», а затем в появившемся окне в панели слева выберите пункт «Чистка системы» => «Неверные ярлыки». В правой части экрана будет доступна соответствующая опция.

  • Польз. файлы к удалению
    В рамках сканирования этого раздела очищаются папки, которые вы вручную задали для очистки в настройках. Вы можете указать программе, какие папки очищать при каждой чистке системы и какие именно файлы (по маске) удалять из них. Узнайте больше о настройке заданных пользователем папок.

  • Старые файлы обновлений
    По умолчанию этот раздел отключен, поскольку его сканирование обычно занимает много времени. О том, как его включить, смотрите ниже.
    Во время сканирования этого раздела очищаются старые копии обновлений Windows, которые становятся не нужны после своей установки, но все равно хранятся в системе. Обратите внимание, что основная работа при очистке данного раздела производится при следующей перезагрузке компьютера. Во время нее система может показывать экран, похожий на тот, что мы видим во время установки обновлений Windows.

Не все разделы чистки системы по умолчанию включены. Чтобы отредактировать список разделов, которые будут просканированы, нажмите на кнопку «Изменить», расположенную рядом с надписью вида «Включено разделов: 16 из 22». Включить все разделы разом можно, активировав режим максимальной чистки.

После завершения сканирования осталось нажать кнопку «Чистить», чтобы запустить процедуру удаления информационного мусора, неверных записей реестра, исправления неверных файлов и т.д.


Режим максимальной чистки

Чистка системы с настройками по умолчанию предназначена для повседневного использования. Однако бывают ситуации, когда требуется освободить как можно больше места на дисках. В этом поможет режим максимальной чистки.

Для его активации переведите во включенное состояние переключатель «Максимальная чистка» в верхней части окна чистки системы. При включении режима вы увидите подсказку с подробной информацией об особенностях его работы.

При использовании инструмента для чистки системы в режиме максимальной чистки будут произведены такие действия, как очистка Корзины и удаление точек восстановления системы (за исключением последней). Подробный список действий можно просмотреть, активировав режим - это не повлечет немедленное удаление данных. После ознакомления со списком производимых действий вы сможете принять решение о том, проводить ли чистку в максимальном режиме.

Если настройки по умолчанию не были изменены вами, то после выхода из программы режим максимальной чистки будет автоматически выключен, и в следующий раз, когда вы запустите инструмент для чистки системы, он будет работать в обычном, повседневном режиме.


Очистка заданных пользователем файлов

Вы можете указать папки, которые нужно очищать полностью или частично во время чистки системы. Если в вашей системе есть временные папки, отличные от стандартных, эта функция программы позволит удалить из них информационный мусор в рамках операции по чистке системы.

Также функция полезна, если требуется удалять только определенные файлы по маске, например, «*.tmp».

Чтобы настроить очистку заданных пользователем файлов, откройте окно настроек, выбрав в главном меню пункт «НАСТРОЙКИ», а затем в появившемся окне в панели слева выберите пункт «Чистка системы» => «Файлы к удалению». В правой части производится добавление и редактирование пользовательских файлов к очистке.

Нажмите «Добавить», чтобы указать новую папку, в которой требуется производить очистку файлов. Далее программа спросит, удалить ли все файлы в указанной папке или только те, что соответствуют маске. В последнем случае маску потребуется задать.


Список исключений

В функциях «Чистка системы» и «Чистка личных данных» используется единый список исключений. Это значит, что если, например, какой-то файл или элемент реестра будет добавлен в исключения одной из этих функций, то он не будет обнаруживаться и в другой.

Добавление в исключения чаще всего производится автоматически. Для добавления в исключения при работе с функцией «Чистка системы» или «Чистка личных данных» достаточно снять галочку на элементе в окне просмотра найденных элементов, имеющем заголовок «Найденные записи». После этого требуется довести чистку до конца. Тогда записи со снятыми галочками добавятся в исключения и не будут обнаруживаться при следующих запусках функций чистки.

Чтобы просмотреть, какие записи в настоящий момент занесены в исключения, перейдите в настройки. Для этого в главном меню программы выберите пункт «НАСТРОЙКИ».

Откроется окно настроек программы. В его левой части можно увидеть древовидный элемент управления, содержащий разделы настроек. Выберете в нем элемент «Чистка системы» или «Чистка личных данных», а затем его дочерний элемент «Исключения». Как было сказано выше, список исключений является единым для обеих функций чистки, поэтому не имеет значения какую из них выбрать.

В правой части окна вы увидите файлы, записи реестра, папки и т.п., находящиеся в исключениях.

Кнопки под списком служат для добавления и удаления записей. Как было сказано выше, добавление записи удобнее делать прямо из окна, содержащего записи, найденные при чистке.


Чистка личных данных

Для чего предназначена эта функция
Выполнение чистки личных данных
Список исключений


Для чего предназначена эта функция

Инструмент предназначен для удаления из системы следов работы за компьютером, содержащих персональные сведения о пользователе. Такие данные постоянно накапливаются во время работы за компьютером.

Если вы являетесь пользователем компьютера, то примером такой информации являются данные сайтов, которые вы недавно посещали в браузере (cookies или «куки»), и списки открытых вами документов, сохраненных системой для быстрого повторного доступа к ним.

Важной особенностью инструмента является чистка следов работы (кэша) установленных сторонних программ.

Периодическая чистка личных данных позволяет уменьшить количество следов, по которым посторонний человек потенциально может определить, что вы делали за компьютером. В то же время проводить ее слишком часто не рекомендуется, т.к. после чистки может потребоваться повторить сделанные вами ранее действия в установленных приложениях. Например, удаление «куков» браузера приводит к тому, что вам придется снова вводить свои данные для входа на некоторые сайты (с настройками по умолчанию чистка браузеров в рамкх чистки личных данных не проводится).

Чтобы чистить личные данные с рекомендуемой частотой, следуйте указаниям фукции «Экспресс-проверка».


Выполнение чистки личных данных

Чтобы открыть инструмент для выполнения чистки личных данных, выберите соответствующую команду в подменю «ФУНКЦИИ» главного меню.

Экран инструмента разделен на 2 части. В левой находятся жестко заданные разделы чистки, а в правом - известные Reg Organizer установленные программы, сведения о которых подгружаются из «облачной» базы данных.

Для того чтобы начать поиск следов личных данных, нажмите кнопку «СКАНИРОВАТЬ». Если вы перешли в этот инструмент из функции экспресс-проверки системы, то нажимать кнопку даже не потребуется, поскольку сканирование начнется автоматически.

Не все разделы чистки личных данных по умолчанию включены: у отключенных разделов снята галочка. Соответственно, для включения раздела в сканирование, нужно поставить галочку напротив него и запустить сканирование заново.

Вы можете включить только те разделы, которые были включены по умолчанию сразу после первого запуска программы. Для этого щелкните правой клавишей мыши на списке разделов и выберите команду «Состояния по умолчанию».

Воспользовавшись тем же контекстным меню, можно легко пометить все разделы чистки или, наоборот, сделать все непомеченными.


Оптимизация реестра

Для чего предназначена эта функция

Выполнение оптимизации реестра


Для чего предназначена эта функция

Инструмент для оптимизации реестра программы Reg Organizer был эффективен в эпоху операционной системы Windows XP и более ранних, а в настоящее время является устаревшим и по умолчанию скрыт в интерфейсе программы. Включить его можно через раздел «Устаревшие инструменты» настроек программы.

Инструмент позволяет произвести дефрагментацию и сжатие файлов, в которых хранится системный реестр.

Для чего нужна дефрагментация реестра
Для чего нужно сжатие реестра


Для чего нужна дефрагментация реестра

В процессе работы с компьютером происходит постоянное обращение к системному реестру, включающее как чтение, так и запись данных. При добавлении информации в реестр производится частичная перезапись файлов реестра на диск. Это может вызвать фрагментацию файлов реестра, когда различные части одного файла оказываются записанными в разных секторах диска.

К чему приводит фрагментированность файлов реестра? На чтение информации из фрагментированного файла реестра требуется больше времени, чем на чтение файла, записанного на диске последовательно.

Инструмент для оптимизации реестра, имеющийся в программе Reg Organizer, позволяет устранить эту проблему. Программа запишет каждый файл реестра на диске последовательно, тем самым устранив фрагментацию.

Дефрагментация реестра в основном эффективна для операционной системы Windows XP и более ранних.


Для чего нужно сжатие реестра

Особенность функционирования операционной системы состоит в том, что при удалении ключа из системного реестра он не удаляется фактически, а лишь помечается как удаленный. Это сделано для ускорения работы с реестром. Ведь если всего лишь помечать ключ, как удаленный, а не удалять его в действительности, то мы получим некоторый выигрыш во времени. Иными словами, операция будет произведена гораздо быстрее.

Однако этот механизм работы имеет недостаток - оставаясь в реестре, удаляемые ключи не уменьшают размер реестра. Информация об удаленных записях может находиться в реестре в течение длительного времени.

Удаленные ключи, оставшиеся в реестре, - это лишь одна из проблем, от которой можно избавиться при помощи функции оптимизации системного реестра программы Reg Organizer. В реестре может присутствовать и другая избыточная и ненужная информация, которая приводит к необоснованному увеличению размера реестра. В таких случаях сжатие приведет к значительному уменьшению размера, занимаемого реестром на диске.

Сжатие реестра в основном эффективно для операционной системы Windows XP и более ранних.


Выполнение оптимизации реестра

Инструмент для оптимизации реестра в настоящее время является устаревшим и по умолчанию скрыт в интерфейсе программы. Включить его можно через раздел «Устаревшие инструменты» настроек программы. Если это сделано, то чтобы открыть инструмент для оптимизации, выберите команду «Оптимизация реестра» в подменю «ФУНКЦИИ» главного меню.

Перед оптимизацией реестра следует закрыть все другие работающие приложения. Это важно, поскольку Reg Organizer во время оптимизации блокирует файлы реестра, вследствие чего в этот момент другие приложения могут работать некорректно и не способны сохранить свои данные в реестре.

Функция оптимизации проста в использовании: в окне данной функции достаточно кликнуть «Выполнить оптимизацию реестра», чтобы запустить эту процедуру. По завершении программа представит результаты и предложит произвести перезагрузку системы. Важно выполнить перезагрузку сразу после завершения оптимизации, т.к. до перезагрузки файлы реестра остаются заблокированными, вследствие чего нельзя записывать в них новую информацию.


Автозапуск программ

Для чего предназначена эта функция

Откладывание программы из автозапуска

Отключение или удаление программы автозапуска


Для чего предназначена эта функция

В инструменте «Автозапуск программ» отображаются приложения и процессы, которые стартуют вместе с системой при включении компьютера (или входе в систему нового пользователя).

При установке приложений они зачастую регистрируются в системе таким образом, чтобы автоматически запускаться при каждой загрузке системы. Назовем это «автоматический запуск» или «автозапуск». Если программа интересна пользователю, то ее автоматический запуск может быть полезен. Однако когда таких программ с автоматическим запуском зарегистрировано много, они могут заметно замедлять загрузку системы, одновременно запускаясь при ее загрузке.

С помощью инструмента «Автозапуск программ» можно увеличить скорость загрузки системы, повлияв на программы, участвующие в автоматическом запуске, с помощью следующих действий:

  • Откладывание запуска программ.

    Если программа находится в автозапуске, то можно сделать так, чтобы она вызывалась не сразу после загрузки системы, а по истечении некоторого времени. Это снизит нагрузку на систему в момент входа в нее, в результате чего она быстрее будет приведена в полностью рабочее состояние, такое, что реакция системы на действия пользователя происходит без задержек.

    Какие программы из автозапуска стоит откладывать? Прежде всего, это те программы, которые не нужны вам сразу после загрузки системы. Например, утилиты для обновления программ, которые производители программ любят добавлять в автоматический запуск.

  • Временное отключение или удаление программ.

    Если вы считаете, что программа не нужна в автоматическом запуске, можно временно отключить, либо постоянно удалить ее оттуда. Это легко сделать с помощью инструмента «Автозапуск программ». При этом он проследит за ситуацией, когда программа, элемент автозапуска которой удалили, вновь создала его. В этом случае элемент автозапуска будет повторно отключен или удален.

В окне инструмента «Автозапуск программ» на графике показано время загрузки системы для нескольких последних загрузок. Следует учитывать, что на это время влияют не только программы в автоматическом запуске, но и множество других процессов (например, фоновые службы, система обновлений Windows и т.д.). Поэтому данному показателю свойственно постоянно меняться как в верхнюю, так и нижнюю сторону.


Откладывание программы из автозапуска

Если вы хотите отложить программу, зарегистрированную в автоматическом запуске, сначала откройте инструмент «Автозапуск программ», выбрав соответствующий пункт в подменю «ФУНКЦИИ» главного меню.

В окне инструмента можно увидеть программы, зарегистрированные в автозапуске текущей системы. Обратите внимание, что отложить можно только те их них, слева от которых в списке есть изображение часов.

Чтобы отложить программу, выберите ее в списке и нажмите кнопку «Отложить загрузку на 30 сек.» (число может отличаться в зависимости от наличия других отложенных программ). Программа будет отложена.

При использовании этой кнопки Reg Organizer сам рассчитывает рекомендуемый интервал откладывания, чтобы «не пересекаться» с другими отложенными программами. Однако вы можете указать и произвольный интервал для откладывания. Чтобы сделать это, щелкните на стрелку справа от кнопки «Отложить загрузку на 30 сек.», а затем в появившемся меню выберите команду «Отложить на, секунд...». Вам будет предложено указать интересующий временной интервал для откладывания выбранной программы.


Отключение или удаление программы автозапуска

Если вы хотите временно отключить или отложить программу, зарегистрированную в автоматическом запуске, сначала откройте инструмент «Автозапуск программ», выбрав соответствующий пункт в подменю «ФУНКЦИИ» главного меню.

Выберите интересующую программу автозапуска, а затем:

  • Чтобы временно отключить программу, щелкните по галочке «Временно отключить». Для отмены этого действия галку потребуется снять.
  • Чтобы удалить программу, щелкните на кнопке «Удалить».


Программы

Общая информация об инструменте «Программы»
Установка новой программы
Работа со списком установленных программ
Просмотр следов, оставленных программой в системе
Удаление программы
Определение внешнего запуска деинсталляторов
Удаление утилитой от разработчиков


Общая информация о функции «Программы»

Для чего предназначена эта функция
Как делается полное удаление программы


Для чего предназначена эта функция

Инструмент «Программы» утилиты Reg Organizer представляет собой мощное средство, позволяющее производить полное удаление приложений с вашего компьютера, включая собственно файлы приложения, записи, которые это приложение оставило в реестре и на дисках, библиотеки, добавленные приложением в системные папки, и т.д. Помимо этого, данный инструмент позволит просмотреть все изменения, внесенные приложением в каждый из перечисленных выше компонентов системы.

Такая функция часто бывает полезной, так как не каждое приложение включает в комплект поставки деинсталлятор, позволяющий корректно и полностью удалить приложение в случае необходимости. Бывают и другие ситуации, когда имеющийся деинсталлятор не удаляет приложение целиком, после чего в системе остается ненужная информация, например, какие-либо записи в системном реестре.

Этот инструмент можно применять не только для удаления приложений, но и, например, для того, чтобы выяснить какие изменения произошли в системе после совершения неких действий, например, запуска какой-либо программы.

Для тех же приложений, удалять которые вам не требуется, инструмент предоставляет возможность их обновлять, устанавливая новые версии. Возможность обновить имеется не для каждого приложения.


Как делается полное удаление программы

Инструмент «Программы» утилиты Reg Organizer поможет без остатка удалить любую программу, установленную на компьютере. Когда вам потребуется удалить какую-нибудь программу, Reg Organizer проведет поиск в системе следов, которые удаляемая программа оставила реестре и на дисках в процессе своей работы, и предложит избавиться от них.

Кроме того, Reg Organizer предоставляет мощную возможность установить любую программу с так называемым отслеживанием. При установке программы таким способом Reg Organizer отслеживает какие изменения вносятся в систему. Слежение включает в себя получение сведений о том, какие записи реестра были модифицированы, какие файлы на дисках были созданы, изменены или удалены, какие динамические библиотеки были добавлены программой установки и т. д. Используя эти данные, отслеженную программу потом можно полностью удалить из системы.

Установка программы с отслеживанием состоит из трех простых шагов. Вам потребуется:

  • Включить отслеживание изменений в системе программой Reg Organizer.
  • Установить программу обычным образом.
  • Завершить отслеживание изменений в системе. Reg Organizer сформирует отчет о том, какие изменения произошли во время установки программы, и сохранит его.

Установленная таким способом программа является отслеженной. При ее удалении через Reg Organizer информация, полученная при отслеживании, будет использована для того, чтобы корректно удалить из системы программу, включая все ее следы.

Для некоторых программ имеется специальная утилита для удаления от разработчика. В этом случае можно гарантированно произвести полное удаление таких программ из системы даже в случае, если стандартное удаление для них по той или иной причине выполнить не удается.


Установка новой программы

За функцию установки программ, равно как и за функцию их удаления, отвечает инструмент «Программы». Поэтому сначала следует открыть этот инструмент, выбрав команду команду «Программы» в подменю «ФУНКЦИИ» главного меню.

Для установки программы с отслеживанием, которое позволит полностью удалить ее при необходимости, откройте окно установки новой программы. Для этого нажмите на кнопку «УСТАНОВИТЬ И ОТСЛЕДИТЬ», расположенную в левой части инструмента «Программы».

Пользоваться окном установки новой программы несложно: после его показа вам будет предложено запустить отслеживание изменений, а затем установить программу обычным образом. Это можно сделать при помощи кнопки «Запустить установку». При ее нажатии вам будет предложено указать путь к файлу программы установки, которая после этого будет запущена.

Под некоторыми операционными системами справа от кнопки «Запустить установку» есть стрелочка, при клике на которую открывается меню с дополнительной опцией запуска программы установки: «Запустить установку в невидимом режиме (если поддерживается)». При ее выборе программа установки будет запущена с параметрами командной строки «/S» и «/Silent». Множество дистрибутивов программ поддерживают такие параметры командной строки, и если они переданы, установка производится без подтверждения от пользователя. Эту опцию полезно использовать, если вы уже не в первый раз устанавливаете программу на компьютер и хотите сэкономить время, избавившись от просмотра ненужных диалоговых окон, показываемых во время инсталляции.

Программу установки можно запустить не только при помощи кнопки «Запустить установку», но и любым другим способом, например, через Проводник Windows.

Желательно, чтобы во время установки программы в вашей системе были закрыты все остальные работающие приложения.


Работа со списком установленных программ

В главном окне инструмента «Программы» можно увидеть список приложений, установленных в системе в настоящий момент.

Чтобы получить более подробную информацию о любой программе, кликните на нее в списке. Также вы можете увидеть все следы, оставленные программой в системе. Для этого кликните на ссылку «Показать все следы». Подробнее об этом описано в этом разделе.

О том, как удалить программу, описано здесь.

Чтобы установить новую программу с отслеживанием изменений, выберите команду «УСТАНОВИТЬ И ОТСЛЕДИТЬ» в левой части окна.

Если программа отслежена, вы увидите полоску в правой части строки списка. Это означает, что установка программы была произведена под контролем, и все изменения, произошедшие во время установки, сохранены и могут быть отменены при необходимости.

Если вы целенаправленно ищете программы, которые можно удалить из системы, например, для освобождения места в ней, то обратите внимание на кнопки, расположенные над списком программ.

Так, при щелчке по кнопке «Большие программы» в списке программ будут отображены только программы большого размера, отсортированные по его убыванию. То, какой размер программ считать большим, задается в настройках.

Есть среди установленных у вас программ есть те, которые можно обновить, то их количество отображается на кнопке «ОБНОВЛЕНИЯ ВАШИХ ПРОГРАММ». Нажмите на нее, чтобы отобразить только их. Для установки новой версии приложения выберите его в списке и нажмите на кнопку обновления с названием вида «Обновить до 2.0». Вы можете обновить все программы сразу, щелкнув на стрелочку на кнопке обновления и выбрав команду группового обновления программ в выпадающем меню.


Просмотр следов, оставленных программой в системе

Чтобы просмотреть, какие следы оставила в системе какая-то из установленных программ, сначала выберите ее в списке. При этом строка списка расширится и появятся сведения о выбранной программе. Кликните на ссылку «Показать все следы», чтобы открыть окно просмотра следов программы, в котором будут отображены все следы, оставленные в ей системе. Если вы не видите эту ссылку, подождите несколько секунд: она появится на месте надписи «Идет анализ...».

Такое же окно со следами программы можно отобразить во время ее удаления.

Если вы производите удаление программы, следы в системе, ассоциированные с ней, можно исключать из процедуры удаления. Так, в окне просмотра следов вы можете выбрать любой ключ реестра или файл на диске и нажать клавишу Delete. После подтверждения соответствующий элемент будет исключен из удаления и останется в системе после удаления программы.

Обратите внимание, что удаление производится не из системы, а только из набора следов, ассоциированных с программой. Например, если вы удалили из окна со следами ключ реестра, помеченный как созданный, то при удалении программы данный ключ не будет удален из вашей системы. Обычно из списка следов, ассоциированных с программой, целесообразно удалять те следы, которые вы хотели бы оставить в системе при удалении программы (обычно такая необходимость возникает редко).

Вы можете не только удалять, но и модифицировать значения параметров реестра, отображаемые в окне следов. Для этого следует выбрать ключ реестра, а затем дважды кликнуть на интересующий параметр в правой части окна просмотра следов программы.


Удаление программы

Откройте инструмент «Программы», выбрав соответствующую команду в подменю «ФУНКЦИИ» главного меню.

В главном окне инструмента работы с программами можно увидеть список приложений, установленных в системе в настоящий момент.

Если программа отслежена, вы увидите полоску в правой части строки списка с надписью «Следы». В этом случае ее можно наиболее всесторонне и основательно удалить из системы. Если же полоска отсутствует, значит, установка программы не была отслежена. В этом случае при удалении программы будет использован алгоритм поиска ее следов в реестре и на дисках. В обоих случаях сначала будет проведено удаление программы с помощью поставляемой с ней утилитой для удаления, если таковая имеется и если при удалении не была выбрана опция принудительного удаления.

Для удаления программы (вне зависимости от того, отслежена она или нет), выберите ее в списке программ в главном окне инструмента для работы с программами, а затем нажмите кнопку «Удалить программу» прямо в строке списка с этой программой. Также удалить программу можно, воспользовавшись контекстным меню на ней в списке.

Если для программы есть специальная утилита для удаления от разработчика, то будет отображаться кнопка «Утилита для удаления от ...» (где вместо троеточия будет подставлено название разработчика выбранной программы).

Удаление программы проводится в несколько этапов:

  • Вызов собственной утилиты для удаления программы.
  • Для отслеженных программ: отмена всех изменений, внесенных в систему при установке программы.
  • Для любой программы: поиск в реестре и на дисках следов, оставленных удаляемой программой в процессе ее работы. В случае нахождения следов Reg Organizer предложит избавиться от них.

На первом этапе производится базовое удаление программы с помощью ее собственного деинсталлятора. На втором этапе производится более глубокая очистка системы от следов удаляемой программы посредством отмены изменений, внесенных в систему при ее установке. На третьем этапе из системы удаляются следы, оставленные программой во время ее работы.

После завершения удаления вы сможете просмотреть отчет, в котором будут перечислены все файлы, ключи и параметры реестра, которые были изменены или удалены в процессе удаления программы.

Если программа не зарегистрирована в системе, но имеет данные отслеживания, то ее можно удалить только из списка, «забыв» данные отслеживания и не внося никаких изменений в систему. Для этого воспользуйтесь командой контекстного меню «Убрать из списка без удаления», которая присутствует только для указанного типа программ.


Определение внешнего запуска деинсталляторов

С помощью этой функции вам не нужно каждый раз вручную запускать Reg Organizer, чтобы удалить ненужную программу и ее следы из системы.

Если вы включите функцию внешнего удаления программы, достаточно просто запустить ее деинсталлятор любым способом, который вы обычно используете для удаления программ в Windows. Вот примеры таких способов: запуск команды удаления из меню «Пуск», удаление через раздел «Приложения и возможности», запуск деинсталлятора непосредственно из папки программы.

После того как вы запустите деинсталлятор программы и произведете ее стандартное удаление, Reg Organizer обнаружит это и предложит удалить следы программы, оставшиеся в системе, если таковые есть.

Чтобы включить эту функцию:

  • Перейдите в Главное меню -> ФАЙЛ -> Настройки...
  • В появившемся окне выберите раздел под названием «Программы» в левой части.
  • Включите настройку «Определять внешний запуск деинсталляторов для чистки следов».

Если эта функция включена, Reg Organizer останется в фоновом режиме после закрытия своего окна, что необходимо для обнаружения внешних деинсталляций. Когда Reg Organizer находится в фоновом режиме, вы всегда можете найти его значок в системном трее (в правом нижнем углу экрана рядом с часами). Это позволяет в случае необходимости отключить функцию обнаружения внешнего удаления.


Удаление утилитой от разработчиков

Для некоторых (но далеко не всех) программ их разработчики предоставляют специальную утилиту, позволяющую произвести полное удаление этой программы из системы. Эта утилита отличается от стандартного деинсталлятора, имеющегося у большинством программ. Часто такие утилиты предоставляют производители антивирусов. Стандартный деинсталлятор в некоторых случаях не может полностью удалить программу или вовсе отказывается работать, если во время установки либо удаления программы что-то пошло не так.

В этих случаях придет на помощь специальная утилита для удаления. Поскольку такие утилиты созданы самими разработчиками программы, они прекрасно «осведомлены» о том, где в системе соответствующая программа прописывает свои данные, настройки и какую защиту от удаления этих элементов необходимо преодолеть, что часто бывает при удалении следов антивирусов.

Чтобы вам не приходилось вручную искать такие утилиты, Reg Organizer выводит все ваши программы, для которых доступна утилита для удаления от разработчиков, в разделе «УТИЛИТЫ ДЛЯ УДАЛЕНИЯ ОТ РАЗРАБОТЧИКОВ» в левой части окна «Программы».

При выборе в списке приложения, у которого доступен такой способ удаления, у вас будет два варианта действий: запустить штатный механизм удаления кнопкой «Удалить программу» и запустить утилиту для полного удаления от разработчика с помощью кнопки вида «Утилита для удаления от ...» (где вместо троеточия будет подставлено название разработчика удаляемой программы).

В первом случае будет запущен классический механизм деинсталляции с поиском следов программы, который выполняется для любой другой программы. Во втором же случае с сайта разработчика будет загружена и запущена специальная утилита для выполнения всестороннего удаления с поддержкой от разработчика.


Редактирование реестра и поиск

Для чего предназначена эта функция
Создание, удаление, редактирование ключей и параметров
Экспорт и импорт реестра
Избранное
Поиск и замена в реестре


Для чего предназначена эта функция

Инструмент «Редактор реестра» предоставляет собой исчерпывающий набор функций для выполнения операций над реестром. Редактор реестра программы Reg Organizer имеет более широкий набор возможностей по сравнению со стандартным редактором реестра Regedit.

Вы можете создавать, удалять и редактировать ключи реестра, а также значения параметров. Кроме того, инструмент предоставляет расширенные возможности, такие как экспорт/импорт определенного ключа или всего реестра в файл, редактирование файлов реестра (.reg) и работа с избранным.


Создание, удаление, редактирование ключей и параметров

Создание, удаление и редактирование ключей и параметров

Чтобы открыть редактор реестра, выберите соответствующую команду в подменю «ФУНКЦИИ» главного меню.

В левой части окна вы увидите дерево ключей, а в правой - список параметров выбранного ключа.

Чтобы произвести операции над ключом реестра, выберите его в списке ключей и нажмите правую клавишу мыши. Отобразится контекстное меню, содержащее команды, относящиеся к ключу реестра. Аналогичным образом можно отобразить контекстное меню команд, связанных с параметрами реестра, если в списке в правой части окна выбрать параметр и щелкнуть правой клавишей мыши по нему.

На панели инструментов вверху окна есть кнопка «Создать». Она позволяет создать ключ реестра или параметры разных типов.


Экспорт и импорт реестра

Программа Reg Organizer позволяет экспортировать данные из реестра в указанный пользователем файл. Также есть возможность совершить обратное действие - импортировать данные из файла в системный реестр. Ниже описаны обе эти возможности.

Экспорт реестра

Команды для экспорта расположены в контекстном меню, вызываемом щелчком правой кнопкой мыши на ключе реестра. Есть несколько вариантов экспорта реестра, каждому из которых соответствует команда:

Контекстное меню -> «Экспортировать ключ...»
Обычный способ экспорта ключа. В файл сохраняется ключ, все его подключи и параметры, имеющиеся как в самом ключе, так и его дочерних ключах.
Контекстное меню -> подменю «Дополнительные функции» -> «Экспортировать ключ без подключей...»
Будет произведен только экспорт выбранного ключа и его параметров. Подключи и их параметры не будут затронуты.
Контекстное меню -> подменю «Дополнительные функции» -> «Экспортировать весь реестр...»
Будет экспортирован весь реестр со всеми его ключами и параметрами.

В программе предусмотрена возможность экспортировать данные в один из двух форматов: «новый», используемый, начиная с Windows XP, и «старый», который использовался в операционных системах семейства Windows 9x и NT.

Тип формата файла реестра задается в диалоговом окне выбора имени экспортируемого файла. По умолчанию файл реестра сохраняется в более современном «новом» формате.

Указанные выше форматы текстовых файлов реестра различаются используемой кодировкой. В более современном формате используется unicode, в то время, как в при записи файлов предыдущего формата используется кодировка ANSI.

Импорт в реестр

Чтобы импортировать данные из файла в реестр, в главном меню программы выберите пункт, состоящий из троеточия: «...», а в нем команду команду «Импортировать данные из файла реестра…».

Также в этом подменю есть команда «Открыть файл реестра...», позволяющая отобразить файл в режиме редактирования: будет показана древовидная структура reg-файла, и вы сможете работать с ним, как с обычным реестром.


Избранное

Очень удобна возможность занесения отдельных ключей или параметров в раздел «Избранное», что позволяет в дальнейшем получать к ним мгновенный доступ.

Для того чтобы занести какой-либо ключ или параметр в Избранное, выделите его в дереве ключей (если это ключ) или в списке параметров (в случае параметра), откройте контекстное меню, нажав правую клавишу мыши. Затем выберите команду «Добавить в Избранное» (в случае ключа) или соответствующую команду, относящуюся к параметру, если был выбран параметр.

Теперь в любой момент времени во время работы с редактором реестра можно будет открыть Избранное, нажав кнопку «Избранное» на панели инструментов. Выбрав интересующий элемент Избранного, можно быстро перейти к нему в редакторе реестра.

Данная возможность позволяет ускорить работу с реестром и сделать перемещение между часто используемыми элементами более удобным.


Поиск и замена в реестре

Выполнение поиска или замены в реестре
Профили поиска и замены


Выполнение поиска или замены в реестре

Чтобы начать поиск в реестре, сначала откройте инструмент «Редактор реестра», расположенный в подменю «ФУНКЦИИ» главного меню.

Для начала поиска необходимо ввести искомую строку в поле ввода, расположенное в верхней части окна инструмента, и нажать кнопку справа от поля.

Если вы хотите произвести замену в реестре, нужно щелкнуть на стрелку справа от кнопки «Начать поиск», в открывшемся меню выбрать «Поиск с заданными настройками...», а затем в появившемся окне отметить галочку «Заменить на:», указав под ней строку замены.

Если вы хотите, чтобы программа показывала каждое найденное совпадение в отдельном окне, отметьте галочку «Показывать совпадения» для перевода поиска или замены в ручной режим.

При замене в ручном режиме программа будет показывать каждое совпадение в отдельном окне и предлагать ввести текст, который следует использовать для замены. При автоматической замене строка для замены указывается только один раз в поле «Заменить на:» в окне «Поиск с заданными настройками».

После установки всех необходимых параметров поиска (или замены) в окне «Поиск с заданными настройками» необходимо нажать кнопку «Начать поиск и сохранить настройки» (либо «Начать замену и сохранить настройки» в случае замены), чтобы приступить к этому процессу.

Найденные совпадения будут отображаться в окне редактора реестра в отдельной области. Вы можете удалять или редактировать их. Для того чтобы отредактировать совпадение, дважды кликните по нему. Программа откроет соответствующий элемент (ключ или параметр) в редакторе реестра, где вы сможете просмотреть или изменить его. Для удаления элемента, расположенного в списке совпадений, из реестра, выделите его и нажмите кнопку «Удалить записи» на панели инструментов над списком. Обратите внимание на контекстное меню. В нем доступна команда для удаления записи либо только из списка совпадений, либо еще и из реестра.

Если для разных ситуаций вы используете разные наборы настроек поиска или замены, используйте профили для быстрого переключения между наборами настроек.


Профили поиска и замены

Профиль поиска и замены - это набор настроек, который можно сохранить под определенным названием, а затем быстро активировать в случае необходимости. Для разных задач могут потребоваться разные наборы настроек, и использование профилей поможет быстро переключаться между наборами настроек, когда это требуется.

Загружать и сохранять профили можно, используя окно «Поиск с заданными настройками». Чтобы открыть его, перейдите в инструмент «Редактор реестра», расположенный в подменю «ФУНКЦИИ» главного меню, а затем щелкните на стрелку справа от кнопки «Начать поиск» и в открывшемся меню выберите «Поиск с заданными настройками...». Элементы управления для работы с профилями находятся в нижней части окна «Поиск с заданными настройками».


Работа с файлами реестра

Что такое файлы реестра
Просмотр структуры файлов реестра
Добавление и редактирование данных


Что такое файлы реестра

Файлы реестра - это файлы текстового или двоичного формата, которые содержат сведения о ключах и параметрах реестра. Данные, содержащиеся в таком файле, можно добавить в реестр, и эта операция называется импортом. Обратная операция записи данных из реестра в файл называется экспортом. О том как провести эти операции написано в этой статье.

Файлы реестра удобно использовать, чтобы вносить одни и те же данные в реестр несколько раз либо на нескольких компьютерах.

Как было сказано выше, файлы реестра могут иметь как текстовый, так и двоичный формат. Файлы первого типа, как правило, имеют расширение «reg». Файлы реестра двоичного формата не имеют строго закрепленного за ними расширения. Программа Reg Organizer позволяет редактировать файлы реестра текстового формата. Двоичные файлы редактировать нельзя, но их можно импортировать и экспортировать.


Просмотр структуры файлов реестра

Чтобы открыть файл реестра для просмотра или редактирования, выполните следующие действия:

  • В главного меню выберите пункт состоящий из троеточия: «...».
  • Выберите команду «Открыть файл реестра...».
  • В диалоговом окне укажите файл, который нужно открыть.

После этого файл реестра отобразится на дополнительной вкладке в окне редактора реестра. Обратите внимание, что интерфейс работы с файлом реестра практически полностью идентичен интерфейсу для работы с самим реестром: доступны все те же команды создания, удаления и редактирования ключей и параметров.

Можно немедленно импортировать содержимое открытого файла в реестр текущей системы. Для этого нажмите кнопку «Импорт» на панели инструментов в верхней части окна редактора реестра, а затем в открывшемся меню щелкните «Импортировать данные этого файла в реестр».

Вы можете открыть несколько файлов реестра и одновременно работать с ними, переключаясь между вкладками этих файлов в окне редактора реестра.

С Reg Organizer удобно просматривать структуру файла реестра перед его импортом. Эта возможность программы делает работу с файлами реестра более безопасной и осмысленной: с ней очень просто увидеть, какие данные будут добавлены в реестр, какие ключи и параметры затронет процедура импорта.

Reg Organizer позволяет включить возможность просмотра файлов реестра прямо из Проводника Windows. При этом в контекстном меню файлов реестра в Проводнике появится команда просмотра таких файлов в Reg Organizer. Узнать больше о данной возможности можно в этом разделе.


Добавление и редактирование данных

Чтобы экспортировать ключ из системного реестра в файл реестра, выберите ключ в дереве ключей на вкладке «Системный реестр» в редакторе реестра, кликните правой клавишей мыши на этом ключе, а затем воспользуйтесь командой контекстного меню «Дополнительные функции» > «Добавить выбранный ключ в».

Вы можете добавить ключ либо в уже открытый файл реестра, либо в новый, который будет создан одновременно с добавлением в него первого ключа.

При редактировании файлов реестра воспользуйтесь кнопкой «Создать» на панели инструментов в верхней части окна, а также контекстным меню на ключах и параметрах. Они открывают доступ к командам для модификации или создания новых ключей и параметров в файле реестра.


Важные разделы реестра

Для чего предназначена эта функция
Просмотр важных разделов реестра
Группировка элементов
Возрасты записей


Для чего предназначена эта функция

Реестр представляет собой базу данных, содержащую информацию о приложениях и компонентах операционной системы, а также ее состоянии и функционировании. Чтобы получить доступ к этой информации, нужно знать в каких ключах реестра и в каком формате хранятся соответствующие данные.

Если вы точно знаете где в реестре находятся нужные ключи и параметры, то для работы с ними можно использовать редактор реестра. В противном же случае, либо если вы хотите сделать обзор информации в реестре более удобным, можно воспользоваться инструментом «Важные разделы реестра» программы Reg Organizer.

Эта функция самостоятельно извлечет информацию из важных разделов системного реестра и представит ее вам для просмотра или редактирования. Различные разделы реестра, доступные для просмотра в этой функции программы, отвечают за те или иные аспекты функционирования операционной системы. Например, раздел «Недавние файлы» отображает список документов, которые недавно открывались в различных программах, запускавшихся на этом компьютере. Раздел «Меню "Открыть с помощью"» позволяет просмотреть и отредактировать список приложений, которые операционная система предлагает при открытии файла неизвестного формата и т. д.

Удаление данных с использованием этого инструмента можно отменить при помощи Центра отмены изменений.


Просмотр важных разделов реестра

Чтобы открыть инструмент «Важные разделы реестра», выберите соответствующую команду в подменю «ФУНКЦИИ» главного меню.

Интерфейс инструмента для просмотра важных разделов реестра состоит из панели выбора раздела реестра в левой части окна и списка с информацией о нем в правой части. Чтобы открыть интересующий раздел реестра, кликните по нему на панели «Разделы реестра», и данные соответствующего раздела будут отображены.

В верхней правой части окна располагается строка поиска, с помощью которой можно задать слово или его часть для отображения в списке только тех элементов, которые удовлетворяют запросу. Это позволяет быстро перейти к необходимой записи, не листая список.

Для облегчения работы со списком элементов и экономии времени программа автоматически определяет заведомо ошибочные записи. Такие элементы списка можно легко отличить от обычных элементов по наличию восклицательного знака на изображении слева от элемента.

В нижней части окна инструмента «Важные разделы реестра» есть небольшой блок с результирующей информацией по выбранному разделу реестра. Из него можно узнать об общем количестве элементов раздела, количестве ошибочных элементов (прямо там можно кликнуть по соответствующей ссылке, чтобы удалить все ошибочные элементы раздела разом).


Группировка элементов

Инструмент для просмотра важных разделов реестра позволяет группировать отображаемые элементы по различным критериям. Для этой цели служит кнопка «Группы», расположенная на панели инструментов в окне просмотра важных разделов реестра.

Можно сгруппировать записи по корректности, возрасту и другим критериям в зависимости от выбранного раздела реестра.

Наиболее важной является группировка по корректности, при которой неверные записи показаны в самом верху списка, что облегчает пользователю выявление проблем. Вы можете сразу же удалить или отредактировать неверную запись.

Чтобы сгруппировать записи по корректности:

  • Нажмите на кнопку «Группы», чтобы открыть меню.
  • Из списка критериев выберите «По корректности».

При таком виде группировки одна из групп содержит неверные записи, другая же - записи, корректность которых программа не может определить самостоятельно. Опытные пользователи могут выявлять некорректные записи из этой группы самостоятельно.


Возрасты записей

При работе с инструментом для просмотра важных разделов реестра есть возможность группировки записей по возрасту. Благодаря ей можно отслеживать появление новых записей в системном реестре, включая новые программы, новые элементы автозагрузки, новые расширения файлов и т.д.

Чтобы сгруппировать записи по возрасту:

  • Нажмите на кнопку «Группы» на панели инструментов в окне инструмента для просмотра важных разделов реестра.
  • Из списка критериев выберите «По возрасту».

Записи автоматически сгруппируются в две категории: «Новые» и «Старые».

Записи помечаются как старые спустя два дня с момента их первого просмотра в Reg Organizer. Однако вы можете вручную поменять их возраст на «новые» и обратно. Для этого выберите или отметьте галочкой требуемые записи, а затем щелкните по любой из них правой клавишей мыши. Затем в подменю «Возрасты записей» выберите соответствующий пункт.


Тонкие настройки

Для чего предназначена эта функция
Быстрая настройка компьютера под определенные цели
Изменение тонких настроек
Создание, изменение и обмен тонкими настройками


Для чего предназначена эта функция

Тонкая настройка - это параметр в реестре, связанный с какой-либо возможностью операционной системы, нередко скрытой и труднодоступной через стандартный интерфейс. Например, с помощью тонкой настройки можно добавить в контекстное меню Проводника функцию «Копировать в папку...», позволяющую быстро скопировать выбранный файл в произвольную папку. Другой пример: тонкая настройка, позволяющая уменьшить время, по истечении которого зависшее приложение будет принудительно выгружено при выключении Windows. В некоторых случаях это уменьшает время, требуемое на выключение компьютера.

Тонкие настройки могут объединяться в группы, предназначенные для достижения какой-то цели, например, ускорения Интернет-соединения. Это так называемые группы быстрой настройки. Неопытным пользователям рекомендуется начать освоение тонких настроек именно с этой возможности программы Reg Organizer. А более опытные пользователи оценят возможность ручного изменения отдельных тонких настроек.

Пользователи-эксперты получили возможность создавать свои собственные тонкие настройки и группы.

Чтобы начать работу с тонкими настройками, выберите команду «Тонкие настройки», расположенную в подменю «ФУНКЦИИ» главного меню.


Быстрая настройка компьютера под определенные цели

Тонкие настройки можно объединять в группы, имеющие статус включено/выключено. Это так называемые группы быстрой настройки. Включение такой группы означает, что все тонкие настройки, входящие в нее, принимают определенное заранее заданное состояние. Принцип работы таких групп более подробно описан здесь.

С программой Reg Organizer поставляются несколько групп быстрой настройки, предназначенных для достижения какой-то цели, например, ускорения Интернет-соединения. Чтобы просмотреть их, в главном окне тонких настроек кликните на ссылку «Настроить свой ПК, включив группы быстрой настройки», при этом содержимое окна под ней раскроется, и вы увидите список групп быстрой настройки, доступных в программе.

Чтобы включить группу быстрой настройки, щелкните по ней в списке, после чего нажмите кнопку «Включить. При этом будут применены настройки, входящие в группу, и вы сможете просмотреть список настроек, которые были изменены. Выключение группы производится аналогичным образом.

Часто после включения или выключения групп быстрой настройки требуется перезагрузка системы либо выход из нее и последующий вход, чтобы настройки вступили в силу.


Изменение тонких настроек

Вы можете вручную менять тонкие настройки, доступные в программе Reg Organizer. Все настройки, доступные для изменения, можно увидеть, щелкнув на ссылку «Вручную менять различные тонкие настройки».

Тонкие настройки распределены по группам в зависимости от их предназначения. Для изменения тонкой настройки требуется выбрать ее, в появившемся окне указать новое значение и нажать кнопку подтверждения.

По умолчанию в списке не показываются тонкие настройки, которые входят во включенные группы быстрой настройки. Это делается по той причине, что если вручную изменить состояние одной из таких тонких настроек, то может отключиться группа быстрой настройки, в которую она входит. Благодаря такой фильтрации можно вручную менять любые тонкие настройки, не беспокоясь о том, что это приведет к отключению какой-то из групп. Однако если вы все же желаете отобразить абсолютно все тонкие настройки, фильтрацию можно отключить. Для этого нужно щелкнуть на ссылку под списком, которая появляется в случае, если в текущем представлении имеются тонкие настройки, входящие во включенные группы быстрой настройки.

Поскольку при включении групп тонкие настройки, входящие в них, по умолчанию не показывается, общее число настроек, которое отображается в заголовках вкладок, может меняться в зависимости от состояния групп быстрой настройки.


Создание и изменение тонких настроек

Возможности по работе с тонкими настройками для опытных пользователей
Группы
Создание тонких настроек


Возможности по работе с тонкими настройками для опытных пользователей

Чтобы перейти к окну, позволяющему модифицировать тонкие настройки и группы, а также экспортировать их, перейдите в главное окно функции тонких настроек и щелкните на ссылку «Создавать тонкие настройки и группы».

В появившемся окне слева вы увидите список групп. Если щелкнуть по одной из них, справа отобразится список тонких настроек, входящих в нее, либо приглашение добавить тонкую настройку, если группа пока пустая.

Вы можете свободно переносить тонкие настройки из одной группы в другую. Для этого требуется «захватить» элемент в списке справа и перетащить его на название группы в левой части окна. Если тонкая настройка переносится из группы «Все», то происходит копирование: элемент остается как в группе «Все», так и в новой группе. Если же тонкая настройка переносится из группы, отличной от «Все», то будет произведено перемещение: элемент пропадет из старой группы и окажется в новой.

В данном окне вы можете создавать группы тонких настроек, группы быстрой настройки, а также отдельные тонкие настройки.

В отличие от главного окна функции тонких настроек, в данном окне отображаются и те тонкие настройки, которые не применимы к текущей операционной системе. Они показываются серым шрифтом.

Можно отменить все изменения, внесенные в тонкие настройки и группы, щелкнув на ссылку «Восстановить первоначальное состояние групп» в нижней части окна. Обратите внимание, что будeт восстановлены не состояния тонких настроек и групп, а их свойства и то, в каких группах они расположены. То есть изменения в систему, внесенные путем изменения настроек и групп, не будут отменены. Однако будут удалены все вновь созданные тонкие настройки, добавлены удаленные, а измененные свойства тонких настроек (например, названия) возвращены к состоянию на момент установки программы.


Группы

Группа тонких настроек
Группа быстрой настройки


Группа тонких настроек

Несколько тонких настроек можно объединить в группу. Каждая группа будет отображаться на отдельной вкладке в главном окне функции тонких настроек. Например, можно создать группу «Визуальные эффекты», чтобы выделить в нее тонкие настройки, влияющие на внешний вид операционной системы..

Таким образом, группа тонких настроек лишь объединяет несколько элементов под одним названием и ее нельзя включить и выключить, в отличие от группы быстрой настройки.

Чтобы создать группу, нужно в левой части окна «Тонкие настройки (раздел для опытных пользователей)» кликнуть на надпись «Создать группу...», а затем в правой части окна нажать одноименную кнопку. При этом опция создания группы быстрой настройки под кнопкой должна быть отключена. Останется отредактировать название группы и нажать кнопку для завершения создания.

Сразу после создания новая группа не содержит ни одной тонкой настройки. Вам будет предложено создать первую тонкую настройку новой группы, либо перенести уже созданные тонкие настройки из других групп.


Группа быстрой настройки

Группа быстрой настройки позволяет объединить в себе несколько настроек, присвоив каждой из них так называемое групповое состояние. Это состояние, которое тонкая настройка приобретает при включении группы быстрой настройки, в которой она содержится. Таким образом, пользователь может включить группу быстрой настройки. Это приведет к тому, что все настройки, входящие в ее состав, приобретут групповые состояния. Для каждой из них групповое состояние задается отдельно.

Например, если тонкая настройка имеет 2 состояния: «включено» и «выключено», то можно добавить ее в группу быстрой настройки и присвоить групповое состояние «выключено». Тогда при включении группы быстрой настройки указанная тонкая настройка приобретет состояние «выключено».

При выключении группы быстрой настройки все состояния настроек, входящих в нее, возвращаются к состоянию, которое было до момента включения.

Когда вы добавляете тонкую настройку в группу быстрой настройки, нужно задать для нее групповое состояние, в противном случае включение группы не приведет к изменениям в состоянии этой настройки. Чтобы задать групповое состояние, выберите тонкую настройку, находящуюся в группе быстрой настройки, и в появившемся окне укажите групповое состояние.

При переносе тонкой настройки из одной группы быстрой настройки в другую ее групповое состояние сохраняется, но если перенести ее в обычную группу, то оно теряется.

Можно использовать группу быстрой настройки для объединения в ней тонких настроек с групповыми состояниями, приводящими к достижению единой цели. Например, группа быстрой настройки, включение которой приводит к отключению всех визуальных эффектов операционной системы для повышения ее быстродействия.


Создание тонких настроек

Тонкая настройка в программе Reg Organizer изменяет определенный параметр реестра. Например, вы можете создать тонкую настройку, у которой есть 3 состояния: «мало», «средне» и «много». Пусть состояние настройки базируется на целочисленном параметре Speed в ключе реестра HKEY_CURRENT_USER\Software\MyApp\Settings. Состоянию «мало» будет соответствовать значение параметра Speed, равное 10. Состоянию «средне» будет соответствовать 100 и «много» - 1000. Если переключить такую тонкую настройку в состояние «много», в параметр Speed указанного ключа реестра запишется число 1000 и т.д.

Можно задать более гибкое состояние настройки, например, такое, для которого значение параметра реестра содержит любое число больше 100.

Чтобы создать тонкую настройку, нужно в окне «Тонкие настройки (раздел для опытных пользователей)» нажать кнопку «Создать тонкую настройку...», а затем пройти через несколько шагов процедуры создания, указав параметры создаваемой тонкой настройки.

При создании тонкой настройки ее текстовые параметры могут быть многоязычными, для этого требуется поставить соответствующую галочку рядом с таким параметром, например, названием. Многоязычность означает, что название будет отображаться по-разному в зависимости от языка. В этом случае потребуется задать название для каждого из поддерживаемых языков.

Для каждой создаваемой тонкой настройки указываются операционные системы, под которыми она работает. Если тонкая настройка не поддерживается текущей операционной системой, она не будет видима в главном окне функции тонких настроек, но будет отображаться шрифтом серого цвета в окне «Тонкие настройки (раздел для опытных пользователей)»


Снимки реестра

Для чего предназначена эта функция

Создание снимка реестра

Сравнение снимков реестра


Для чего предназначена эта функция

Иногда бывает полезно определить какие изменения вносятся в системный реестр во время выполнения какой-либо операции. Например, вы хотите узнать какие изменения происходят в реестре при работе некоторой программы. В этом поможет функция «Снимки реестра».

Данная функция позволяет сделать и сохранить любое количество снимков реестра вашей системы. Затем можно выбрать любой снимок и выявить различия между ним и текущим реестром. Таким образом, программа позволяет узнать какие изменения претерпел реестр в промежутке времени между созданием выбранного снимка и текущим моментом.


Создание снимка реестра

Чтобы открыть инструмент для работы со снимками реестра, выберите команду «Снимки реестра» в подменю «ФУНКЦИИ» главного меню.

Снимок реестра - это текущее состояние всего реестра или его части, сохраненное на диске.

Можно создать снимок как всего реестра, так и отдельно взятых ключей.

  • Чтобы создать снимок всего реестра, нажмите кнопку «Создать снимок», после чего снимок будет создан.
  • Чтобы включить в снимок реестра только некоторые ключи, нажмите на стрелочку, расположенную справа от кнопки «Создать снимок», и в появившемся меню выберите команду «Только некоторых ключей». В появившемся окне пометьте «галочкой» те ключи, которе вы хотите включить в снимок, а затем нажмите «ОК» для его создания.


Сравнение снимка и текущего реестра

Выявить изменения между снимком реестра и текущим реестром предельно просто: вам нужно выбрать интересующий снимок, а затем нажать на кнопку «Сравнить с текущим реестром».

Данная функциональность также доступна в контекстном меню наряду с другими командами, связанными со снимками реестра.


Дополнительные функции программы

Центр отмены изменений
Изменение настроек
Интеграция в оболочку


Центр отмены изменений

Вы можете отменить изменения, внесенные в систему при работе со многими инструментами Reg Organizer. В этом поможет Центр отмены изменений. Например, он позволит отменить изменения, внесенные вами через редактор реестра программы Reg Organizer, восстановить следы удаленных программ, просмотреть измененные недавно тонкие настройки системы и т.д.

Чтобы просмотреть что можно восстановить, щелкните на кнопку «ВОССТАНОВИТЬ», расположенную в правом нижнем углу главного окна программы. Эта функция также доступна из подменю в виде трех точек («...») главного меню.

В окне функции показываются все изменения, которые можно отменить или просмотреть, в хронологическом порядке. Для просмотра подробностей об изменении выберите его в списке. Для отмены изменения, выберите его и нажмите кнопку под списком.

Можно переименовать изменение, воспользовавшись командой контекстного меню.

Вы можете удалять изменения, не отменяя их, если считаете, что они больше не нужны. Но делать это для того, чтобы избавиться от устаревших данных, необязательно: старые элементы удаляются автоматически по мере работы с программой Reg Organizer.


Изменение настроек

После установки программа Reg Organizer уже настроена наиболее оптимальным образом. Однако можно изменить некоторые настройки, касающиеся функционирования программы. Чтобы открыть окно настроек, выберите пункт «НАСТРОЙКИ» главного меню программы.

Все настройки программы рассортированы по категориям. В левой части окна можно увидеть эти категории (в древовидной форме). При нажатии на категорию в левой части окна открываются опции, соответствующие этой категории.

Чтобы закрыть окно с сохранением внесенных изменений, нажмите «OK». Чтобы закрыть окно без внесения изменений, нажмите кнопку «Отмена»

Вы можете восстановить настройки по умолчанию. Для этого нажмите на ссылку «Вернуться к настройкам по умолчанию» в нижней части окна настроек. Затем нажмите «OK», чтобы сохранить состояние настроек.


Интеграция в оболочку

Вы можете вызывать важные функции программы Reg Organizer прямо из Проводника Windows. Чтобы открыть раздел настроек программы, которые отвечает за интеграцию Reg Organizer в оболочку, выполните следующие действия:

  • Выберите пункт «НАСТРОЙКИ» главного меню программы.
  • В древовидном списке категорий в левой части окна выберите «Общие».

На этой вкладке есть опция «Команды в контекстном меню Windows», которая позволяет включить или выключить интеграцию Reg Organizer с оболочкой. Вот какие команды добавятся в контекстное меню Проводника Windows, если эта опция включена:

«Запустить и отследить в Reg Organizer» у исполняемых файлов и программ установки
Используется для запуска программ установки с отслеживанием. Отслеживание выявляет изменения, вносимые программой установки в систему, чтобы затем при необходимости отменить их, полностью удалив установленную программу из системы.
«Удалить полностью с помощью Reg Organizer» у ярлыков
Reg Organizer позволяет удалить любую установленную программу и следы ее присутствия в системе. Если выбрать эту команду на ярлыке программы, начнется процедура ее полного удаления из системы.

Имейте в виду: чтобы произвести удаление ненужной программы, не обязательно даже запускать Reg Organizer, а достаточно просто перетащить ярлык удаляемой программы на ярлык Reg Organizer на Рабочем столе. После этого начнется процедура удаления.
«Открыть в Reg Organizer» у файлов с расширением «.reg»
С помощью этой команды можно открывать файлы реестра прямо из Проводника Windows, просматривая их в наглядной форме с отображением древовидной структуры ключей. Эта команда удобна тем, что позволяет узнать какие данные содержатся в reg-файле перед его импортом в реестр.


Обратная связь

Если у вас есть комментарии относительно программы Reg Organizer, вы нашли недочет или хотите предложить какую-либо новую функцию, которой нет в текущей версии программы, обратитесь в нашу службу поддержки по электронной почте support@chemtable.com или посетив наш форум.

Ваши пожелания, комментарии, сообщения об ошибках очень важны для совершенствования программы. Множество идей, воплощенных в программе, были взяты из писем пользователей. Поэтому если у вас есть мысли относительно улучшения нашего программного продукта, пожалуйста, изложите их, связавшись с нами указанными выше способами.

Последняя версия программы Reg Organizer всегда доступна на сайте www.chemtable.com.


Выберите один из вложенных элементов списка, чтобы получить информацию по нему.